Vous désirez installer la dernière version de votre site qui demande PHP 5.4 ou PHP 5.5 , mais vous avez un script métier qui ne tourne que sur PHP 5.3 ?

Découvrez comment adapter la version PHP de vos dossiers en quelques clics depuis le panel d’administration de votre hébergement web LWS.

Nos hébergements web linux proposent déjà de choisir la version de PHP que vous désirez par défaut. La procédure à suivre est disponible sur notre rubrique d’aide.

Vous pouvez choisir la version de PHP utilisée par défaut sur votre hébergement. Mais vous pouvez aussi choisir une autre version de PHP pour un dossier en particulier :

1. Commencez par choisir le version par défaut dans votre espace client. Il est préférable de choisir la version de PHP la plus élevée. Le changement est appliqué dans l’heure.

Capture d'écran - 21082014 - 15:54:30

2. Par FTP, crée ensuite un dossier qui accueillera vos scripts devant être exécutés avec la version 5.3 de PHP (si il n’existe pas encore).

Capture d'écran - 21082014 - 16:24:07

3. Dans ce dossier, créez un fichier .htaccess ou modifier le fichier .htaccess déjà présent avec le contenu suivant :

AddHandler php53 .php

Vous pouvez vérifier la version de PHP qui est exécutée dans un dossier en créant un fichier phpinfo.php dans ce dossier avec le contenu suivant :

<?php
phpinfo();
?>

Visitez ensuite cette page sur votre navigateur:

http://domaine.com/dossier/phpinfo.php

 

Capture d'écran - 21082014 - 16:23:37

Vous pouvez alors installer vos scripts nécessitant la version 5.3 de PHP dans ce dossier.

Quelles sont les versions PHP disponibles ?

  • Les versions de PHP disponibles sont 5.3, 5.4, 5.5 et 5.6. La version 5.4 est la version par défaut lors de la livraison de votre hébergement. Vous pouvez donc utiliser, au choix, une des directives suivantes dans votre fichier .htaccess
AddHandler php53 .php
AddHandler php54 .php
AddHandler php55 .php
AddHandler php56 .php
  • Si la visite de la page phpinfo.php n’affiche pas de contenu, vérifiez votre fichier .htaccess . Il y a de forte chance que vous ayez choisie une version inexistante sur nos hébergements ( php52 par exemple ).
  • Si la visite de la page phpinfo.php ne donne pas la version désirée de PHP, vérifiez tout d’abord que le fichier .htaccess n’a pas d’erreur. Si non, allez dans votre espace client LWS et sélectionnez la version de PHP désirée. Validez. La version de PHP désirée sera activé dans l’heure.

INFO : PHP a annoncer que le version PHP 5.3 arrivait en fin de vie. Nous vous conseillons de migrer, si votre site le permet, vers une version supérieur de PHP.